Problem:
- Some issues were overlooked by the tester.
Cause of the problem:
- Most QA’s are fresh graduates and not familiar with the areas to check and how to formulate positive and negative scenarios.
Solutions:
- As a solution to the issue with new QA’s, we would be involving the other senior QA’s to mentor newbies to guide them. Have a buddy system during mentoring. One senior is assigned to a newbie for all questions and clarifications.
- Also continue what we started last year regarding the brown bag session where each QA is given a topic related to testing and have a discussion with the team so they are aware of other testing stuff.
- Include those repetitive issues found by clients or areas commonly overlooked and discussed in the QA weekly meeting.
- Include coordination with PMs for the QA training.
- Compile an onboarding process document in order to serve as a guide to both old and new QA’s with regards to certain processes.
Problem:
- QA's are not aware of the development activity
Cause of the problem:
- QA’s are not included on the channel they created
- No idea or not involved during the handoff of the feature being developed.
Solution:
- Coordinate with the PM team to make sure that QA’s are added on the right channel and are involved in the handoff of features and other items being developed.
Problem:
- QA's need to have their own unit testing script .
Cause of the problem:
- QA’s already have their assigned classes, but it was stopped because of the constant change in the requirements and at that time, developers cannot accommodate inquiries from QA’s because of their task that needs to be delivered on time.
Solutions:
- Implement unit testing script
- Test page by page and make revisions as we go along.
- Document that shows the process of doing this.